This application note describes RFIC EM modelling with Empire XPU using a technology template. The technology template used in this example is IHP SG13S / SG13G2.

Technology information is only disclosed under an NDA with the foundry, so the templates are not included in the regular Empire XPU setup. An initial setup for the technology is required. Once configured, the RFIC technologies are available just like the other Empire templates.

Create new 3D EM project using the template

To create a new IHP SG13S model, do File > New Project and choose IHP > SG13S from the template list. At the top of the setup window, you find settings that are common to all Empire templates, e.g. frequency range. Below are technology-specific settings like substrate thickness, and also simulation area size.

Adjust end frequency and the simulation target frequency as required.  Loss models are automatically changed to wideband lossy when creating your model, you do NOT need to change these parameters.

Click on “Open Selection” to create a new project with these settings. In the project tree, you will see all the metal, via and dielectric layers defined by the SG13 template. Metal and via layers are empty so far, but you can start drawing immediately if you wish: just select the drawing layer and start drawing! On substrate, oxide and passivation layers, the template has created a simulation area automatically. Some of these layers are hidden by default, for a cleaner editor view.

Import layout from GDSII

Layout import from GDSII is fast & easy because the template comes with the corresponding layer mapping file.

Use File > Import > 2D Layouts > GDSII and select your file. Empire will read the file, and then show a layer mapping dialog. Click “Import Map” and load the SG13 layer mapping file. Then, click “Import” to read in your geometry and finally click “Close” to close the dialog.

The layer mapping file directs geometries to the correct template layers, and each template layer is preconfigured for the correct position, thickness and material. You now see the imported model in the Empire 2D and 3D editor:

In the 3D editor, you will notice a gray block underneath the inductor. This geometry was included in the GDSII file, and represents the air for SG13 LBE option (localized backside etching). The substrate itself is not shown in the editor by default, because the SG13 template sets this layer to hidden.

How does Empire handle the LBE hole (air) inside the substrate block? This is handled by assigning material priorities, so there is no need for boolean operations on the intersecting geometries.

Adjusting the simulation area

For this layout example, the default simulation area size from the template is fine. In other cases, the simulation area size can be adjusted easily using the parameters xmin, xmax, ymin, ymax. To show how these parameters change all the layers simultaneously, the substrate and passivation layers and air above have been switched to visible in the screenshot below.

Adding ports for simulation

To complete the model, we need to add ports. My personal preference is to use the 2D editor for adding lumped ports, so we switch to the 2D editor with top view and zoom into the inductor feed area.

In the project tree, select the layer where you want to place the port. For our SG13 example, this is TopMetal2.

Move the mouse cursor over the edge of the inductor feed. The cursor with change to a diamond at the center of the edge. Press down the left mouse button, and keep it down while you are moving the mouse to the edge of the ground polygon. When you release the mouse, you will see an arrow, which is where we create the port (source).

Click on the Create Source icon, then select the “In-Plane Port”. Input parameters for the port are shown at the left side of the editor window. Click on “Parameters” and change the port width to 10 (=same as line width), then press OK to close the dialog. Press OK again to close the parameter settings at the left side.

You now see the port with correct width on layer TopMetal2. Repeat this step to create the second port.later. Alternatively, you can also copy port 1 and change the port number of the copy to port 2. Use File > Save to store your model.

Edit in 2D or 3D mode?

Many “planar” edits are faster in the 2D editor, but the choice is up to you.
You can switch between 2D editor and 3D editor at any time!

Solver settings

Before you start simulation, use Edit > Simulation Options and verify that settings are appropriate for your model. The “Structure Type” setting provides an easy way to configure various mesh settings for typical applications.

Template default are absorbing sheet boundaries that can absorb some radiation, but for antenna simulation you should change boundary conditions to better absorbers (perfectly matched layers) with less reflection.

Check mesh

To check the simulation mesh, create the mesh using the “Create Mesh” icon.

You can then check the mesh visually using the “Meshed 3D structure” icon, or use the “Design Check” function to open the Mesh Info display in the project tree.

Verify that there are no extremely small mesh cells in any direction, because that would force a small timestep that slows down simulation. For reference: the passivation layer thickness determines the mesh size in y direction, with a value of 0.4 µm. Cells in x and y direction are usually larger than that.

If required, you can limit the minimum and maximum mesh size using a global setting, or per layer, but that’s a topic is for another application note...

Ready for simulation

The model is now ready for simulation. With Empire XPU, you can simulate on the local computer by pressing the simulate button. You can also send simulation jobs to a remote machine, to an in-house simulation cluster or to an Empire solver running on Amazon’s EC2 cloud service.

That finishes our application note on Empire XPU 3D EM modelling with IHP SG13 technology.